Devel::ModInfo::Dependency

Devel::ModInfo::Dependency - Defines a module's dependency on a particular version of Perl or a certain module

SYNOPSIS

Not meant to be used outside the ModInfo system. =head1 DESCRIPTION

Devel::ModInfo::Dependency has two types of dependencies at present: PERL and MODULE. PERL dependencies mean that a module requires a certain version of Perl, as declared in Perl code using something like the following:

require 5.005;

The MODULE dependency means that the module in question requires another module be available, as in defined in Perl using something like this:

use XML::DOM;

These statements appearing in your code are a good indicator that a ModInfo::Dependency could be defined.

AUTHOR

jtillman@bigfoot.com tcushard@bigfoot.com

SEE ALSO

Devel::ModInfo::Tutorial

perl(1).